登录 | 注册 | FAQ
Anonymous

@font_face não funciona

+ 发表回复

3 篇帖子 分页: 1 / 1


@font_face não funciona

Keite Tuane » 周三 3月 13, 2013 6:56 pm

Boa Tarde Pessoal,


Tenho uma aplicação ASP.NET 4.0, Web Application, usando Forms Authentication.
Realizei as configurações para modo de autenticação Forms, restringi o acesso a apenas duas pastas na raiz e
habilitei acesso irrestrito às outras, como: pastas CSS, Image e Script.

Ao rodar a minha aplicação pelo Visual Studio 2010 o estilo e as imagens aparecem normalmente.
Entretanto, ao rodar a aplicação através do IIS no meu computador local (Windows 7 Professional / IIS 7)
ou publicado no servidor (Windows Web Server 2008 R2/ IIS 7.5) os estilos de font não funcionam.

Não sei mais se o problema está nas configurações do IIS ou se meu @font-face não está funcionando corretamente.

No meu .css declaro o @font-face assim:

/* CSS DOCUMENT */

@font-face
{
font-family: 'Swis721 Cn BT';
src: url('~/Content/fonts/swiss_721_condensed_bt-webfont.eot');
src: url('~/Content/fonts/swiss_721_condensed_bt-webfont.eot?iefix') format('eot'),
url('~/Content/fonts/swiss_721_condensed_bt-webfont.woff') format('woff'),
url('~/Content/fonts/Fswiss_721_condensed_bt-webfont.ttf') format('truetype'),
url('~/Content/fonts/swiss_721_condensed_bt-webfont.svg#webfontZam02nTh')format('svg');
font-weight: normal;
font-style: normal;
}

E a utilizo assim:

h1
{
color: #181818;
font-family: "Swis721 Cn BT", "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: normal;
}

Pelo que percebi, o navegador lê somente a Helvetica Neue, Helvetica, Arial e sans-serif.

Já testei no FF, IE9 e Chrome.

Alguém teria alguma idéia do que possa ser e/ou como consigo resolver. Não tenho muito conhecimento em IIS e CSS, não sei
se um influencia o outro. Ou qual poderia ser o problema.

Agradeço desde já a colaboração.
头像

Keite Tuane

  • 帖子: 2
  • 注册: 周三 3月 13, 2013 6:54 pm

Re: @font_face não funciona

Keite Tuane » 周五 3月 15, 2013 1:49 pm

Pessoal, resolvi da seguinte forma:

Adicionei as permissões para o ISS_IUSRS e Authenticated Users no IIS;
Adicionei as extensões .woff e .svg no MIME do IIS;
E coloquei os arquivos das fontes baixadas diretamente no diretório de fontes do meu site no IIS após publicação.

Testei nos Browsers IE9, Google Chrome e FIrefox19, funcionou em todos perfeitamente.
头像

Keite Tuane

  • 帖子: 2
  • 注册: 周三 3月 13, 2013 6:54 pm

Re: @font_face não funciona

XainPro » 周六 3月 16, 2013 1:57 pm

eu estou feliz que você resolver o seu problema de auto-estudo
头像

XainPro

  • 帖子: 3933
  • 注册: 周五 2月 17, 2012 8:10 pm


+ 发表回复

分页: 1 / 1